RocketDivision.Com Forum IndexRocketDivision.Com
RDS - software that rocks!
 
 FAQFAQ             
        

drive letters

 
      RocketDivision.Com Forum Index -> StarWind
View previous topic :: View next topic  
AuthorMessage
vdc



Joined: 01 Dec 2005
Posts: 1

PostPosted: Thu Dec 01, 2005 10:21 am    Post subject: drive letters

Hi,

When I add a cd-rom as a SPTI-device using starwind the device gets mapped 8 times on initiator (d: e: f: g: and so on), the funny thing is they all work. How is this possible? I use the latest (trial) version of starwind. The initiator card is a Adaptec 7211C
Back to top
valery (staff)



Joined: 29 Jun 2004
Posts: 302

PostPosted: Thu Dec 01, 2005 7:55 pm    Post subject: Re: drive letters

vdc wrote:
Hi,

When I add a cd-rom as a SPTI-device using starwind the device gets mapped 8 times on initiator (d: e: f: g: and so on), the funny thing is they all work. How is this possible? I use the latest (trial) version of starwind. The initiator card is a Adaptec 7211C

Hi,

What is your StarWind version?

I guess the Adaptec HBA (unlike other initiators) does not use SCSIOP_REPORT_LUNS to enumerate available LUNs and tries first 8 LUNs directly.
The Windows ATA/ATAPI storage port seems not to check the LUN parameter in requests, so it returns the same INQUIRY data to any LUN value.
That's why you have multiple instances of the same drive.

Thank you for the information.
We'll remove the issue in the next update of StarWind.
_________________
Best regards,
Valery
Back to top
      RocketDivision.Com Forum Index -> StarWind
Page 1 of 1